Erro de Permissão no WordPress

Eu uso o plugin AdSense Deluxe no WordPress e depois que atualizei WP pra versão 2.9.1, comecei a ter erro de “Sem permissões suficientes para acessar esta página” ao tentar abrir a página de configuração deste plugin, mesmo logado como admin.

Não encontrei nada na Internet especificamente deste erro, mas peguei o arquivo de tradução do WP e achei a mensagem original em inglês: “You do not have sufficient permission to access this page”. Com esssa mensagem foi mais fácil encontrar a solução pro problema. Encontrei até um post que falava diretamente do erro do AdSenseDeluxe.

A solução é bem simples, basta trocar a função “admin_head()” por “admin_menu()” no código fonte do plugin. Está na linha 1085.

Deixe um Comentário

8 Comentários.

  1. Cara, você fez uma pessoas feliz hoje!!! Parabéns pelo post.
    Funcionou certinho.

  2. Obrigado,

    Me ajudou resolver o problema…

  3. Show de bola!!
    Muito obrigado pela solução, a sua iniciativa foi 10.
    Fique na paz!
    vlwwwwwwwwwwwwwwww!

  4. Henrique MUITO OBRIGADO! Muito mesmo já estava desistindo ainda bem que encontrei sua dica. Abraços Muito Sucesso

  5. cara estava desde ontem testando link por link no google e nenhum tinha minha solução ate q encontrei o seu 😀 Muito Obrigado

  6. Opa! Legal.

    Eu costumo postar no blog solução de problemas que não encontro facilmente pelo Google, pois tenho certeza que algum dia alguém irá precisar dessa solução.

    Fico muito contente de saber que fui útil!

  7. Obrigado pela dica, estava com este problema e agora já está resolvido.

    abraço

Não fique de fora, dê sua opinião!

%d blogueiros gostam disto: